Autocomplete http:// not working in Internet Explorer

Most of all traditional web browsers provide a key feature that populate partially typed website name automatically appeared on the web browser. we usually call this feature as autocomplete. The web browser address bar automatically gets filled with the website URL picked from your browsing history prefixed by http://. But some situations the autocomplete http:// not working in Internet Explorer due various problem resources such as Virus or malware infection.




Platform: Windows

Autocomplete http:// not working in Internet Explorer:


In this article let’s learn how to bring an autocomplete feature in Internet Explorer which prefixes the http:// automatically in address bar.

Solution:


The possible problem could there be registry corruption. Perform the below steps to correct the registry.

Note:
Before making the below-suggested registry changes, I would suggest running an Anti-Virus program to disinfect any Virus if infected to your computer, which causes your Internet Browser application not functioning correctly. Then check if the auto-complete feature is working.

Check whether the default http:// prefix is correctly configured.



1
Open Registry Editor (regedit) program and navigate to the following key in the registry.


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\DefaultPrefix

Autocomplete http:// not working in Internet Explorer



2
Check whether DefaultPrefix key has configured to string value http://. If not configured then you need to configure it.


A) Double click on the key name Default which opens the screen to configure the string value.
B) Enter the string value ‘http://’ in the text box.
C) Click on OK button the save the settings.

Autocomplete http:// not working in Internet Explorer

Check whether http:// prefix is configured correctly in other registry location.



1
Open Registry Editor (regedit) program and navigate to the following key in the registry.


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\Prefixes
Autocomplete http:// not working in Internet Explorer



2
Check whether the registry key names such as home, mosaic and www are configured to string ‘http://’ correctly. If not configured, then go ahead to configure each key by editing the string ‘http://’

Note:
Once the above changes are done on the registry, make sure to reboot your computer to effect the changes.




– Article ends here –

If you have any questions, please feel free to share your questions or comments on the comment box below.

Recommended:   VMWare player failed to load virtual OS image
Share this:
We will be happy to hear your thoughts

Leave a reply

Troubleshootyourself
Logo